Jump to content

Help me please


Recommended Posts

Ok so I don't have a Subaru but I have a VW Subaru converstion with an y reg ej20 n/a. No maf sensor.

Anyways this thing doesn't bloody start when the coolant temp sensor is connected. And when I disconnect it and start fires up and then will not idle and cuts out. No faults in ecm the coolant temp is reading what would be expected. Adjusted the TPS with volt meter. 

Does any body know how the idle valve is supposed to get hot when just the ignition is on. I don't want to just parts canon it,trying to diagnose it correctly 1st time. Many thanks 

 

Link to post

Welcome to the forum.

 

Sounds as if you have a problem with the coolant temp sensor - have you tested it/replaced it?

The temp sensor is a double sensor with three pins, two for the ecu the other and earth through the body for the temp guage so the ecu side could have failed.

22630AA11A-2.jpg?v-cache=1569508013

Is it a single or double cam engine??  If it came from a Y reg Impreza it "should be" an EJ201 DOHC  where the idle air control valve is electromechanical and operated by the ECU depending upon the coolant temp.

What is the part number or designation for the ECU?  (22611AF630/31/32/33/34 or T9)

if it's from a Forester it could be an EJ202 SOHC with ECU  22611AG320/21/22 or Z9 - same electromechanical idle air control valve

s-l300.jpg

Link to post

Sorry I have not replied sooner I never knew you had messaged as I didn't get an email lol 

My ECU is a 3H 22611 AF633

I have not tested or replaced the coolant temp sensor, how would you recommend I do this by checking the resistance in some warm water obviously disconnected from ecm and what pins would you use ?? Also the ECU is reading like 20 degrees which I would suspect it to be ok. 

It is out of an Impreza and is SOHC

I have ordered a new IACV but is a cheap one and most likely be the correct one as the seems to be so many different tyres Nd import car part don't do the one I need apparently. 

Link to post

 (My bad it should have been SOHC for both Impreza and Forester in my post above for UK supply).

22611AF633 is from a late MY01 GX Impreza with an EJ201 engine - seems strange they changed the designation from T9 to H3 for AF633 when they are supposed to be interchangeable and form a succession group, obviously something changed with the OEM Map.

Just twigged - All cars built after Jan 1st 2001 have to be ODB compliant so ECU designation changed to reflect this.

IACV is Subaru p/n 22650AA192.

If you haven't already got a copy of the Workshop Manual you can download the various sections from HERE

The SOHC is ENGINE Section 1 (12 PDF sections) and all the wiring diagrams are near the end of the web page (3 downloads)

The Engine coolant temp guage system is the first item in section2 of the wiring diagrams and shows pin number and position (look at the plug images at the bottom of the page for plug shape.

The ECU temp side is shown in the next items for Engine wiring system (RHD SOHC MODEL Pages WI-144 to WI-152) not the earlier RHD without OBD model section)

 

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...